#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<a.+?<\/a>"
Local $sString = "<b>http://url.com</b>" & @CRLF & _
"Use this for the negative lookahead? - <a.+?<\/a>" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo..." & @CRLF & _
"" & @CRLF & _
"http://url.com http://url.com" & @CRLF & _
"gubergren, no sea http://url.com" & @CRLF & _
"" & @CRLF & _
"<a href="http://url.com">" & @CRLF & _
"http://url.com" & @CRLF & _
"</a>" & @CRLF & _
"" & @CRLF & _
"http://url.com <a href="http://url.com">http://url.com</a> http://url.com" & @CRLF & _
"" & @CRLF & _
"http://url.com<a href="http://url.com"><b>http://url.com</b></a>http://url.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")