// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)<a.+?<\/a>").unwrap();
let string = "<b>http://url.com</b>
Use this for the negative lookahead? - <a.+?<\\/a>
Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href=\"http://Test.com/url\">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...
http://url.com http://url.com
gubergren, no sea http://url.com
<a href=\"http://url.com\">
http://url.com
</a>
http://url.com <a href=\"http://url.com\">http://url.com</a> http://url.com
http://url.com<a href=\"http://url.com\"><b>http://url.com</b></a>http://url.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}