const regex = /<a.+?<\/a>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a.+?<\\\/a>', 'ig')
const str = `<b>http://url.com</b>
Use this for the negative lookahead? - <a.+?<\\/a>
Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...
http://url.com http://url.com
gubergren, no sea http://url.com
<a href="http://url.com">
http://url.com
</a>
http://url.com <a href="http://url.com">http://url.com</a> http://url.com
http://url.com<a href="http://url.com"><b>http://url.com</b></a>http://url.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}