use strict;
my $str = '<b>http://url.com</b>
Use this for the negative lookahead? - <a.+?<\\/a>
Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href="http://Test.com/url">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...
http://url.com http://url.com
gubergren, no sea http://url.com
<a href="http://url.com">
http://url.com
</a>
http://url.com <a href="http://url.com">http://url.com</a> http://url.com
http://url.com<a href="http://url.com"><b>http://url.com</b></a>http://url.com';
my $regex = qr/<a.+?<\/a>/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}