import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a.+?<\\/a>";
final String string = "<b>http://url.com</b>\n"
+ "Use this for the negative lookahead? - <a.+?<\\/a>\n\n"
+ "Lorem ipsum Test dolor sit amet, consetetur sadhttp://url.comipscing elitr, sed diam nonumy <a href=\"http://Test.com/url\">Test</a> eirmod tempor invidunt ut labore et dolore magna aliquyam erat, sed diam voluptua. At vero eos et accusam http://url.com et justo...\n\n"
+ "http://url.com http://url.com\n"
+ "gubergren, no sea http://url.com\n\n"
+ "<a href=\"http://url.com\">\n"
+ "http://url.com\n"
+ "</a>\n\n"
+ "http://url.com <a href=\"http://url.com\">http://url.com</a> http://url.com\n\n"
+ "http://url.com<a href=\"http://url.com\"><b>http://url.com</b></a>http://url.com";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}