#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<span.*?(?:itemprop\s*=\s*"\s*name\s*"\s*)?class\s*=\s*"\s*itemprop\s*"\s*(?:itemprop\s*=\s*"\s*name\s*"\s*)?>(.*?)<\/span>"
Local $sString = " <div class="txt-block" itemprop="contractors" itemscope" & @CRLF & _
" itemtype="home"> " & @CRLF & _
" <h4 class="inline">Employs:</h4> <a href="/.../" itemprop='url'><span class="itemprop"" & @CRLF & _
" itemprop="name">Carp 1</span></a>, <a href="/.../"" & @CRLF & _
" itemprop='url'><span class="itemprop" itemprop="name">Carp" & @CRLF & _
" 2</span></a>, <a href="/.../" itemprop='url'><span class="itemprop"" & @CRLF & _
" itemprop="name">Carp 3</span></a> <span" & @CRLF & _
" class="tots">|</span>" & @CRLF & _
" <span class="see-more inline"> <a href="/.../" itemprop='url'>See full options</a> " & @CRLF & _
" </span>" & @CRLF & _
" </div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")