import Foundation
let pattern = #"<span.*?(?:itemprop\s*=\s*"\s*name\s*"\s*)?class\s*=\s*"\s*itemprop\s*"\s*(?:itemprop\s*=\s*"\s*name\s*"\s*)?>(.*?)<\/span>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div class="txt-block" itemprop="contractors" itemscope
itemtype="home">
<h4 class="inline">Employs:</h4> <a href="/.../" itemprop='url'><span class="itemprop"
itemprop="name">Carp 1</span></a>, <a href="/.../"
itemprop='url'><span class="itemprop" itemprop="name">Carp
2</span></a>, <a href="/.../" itemprop='url'><span class="itemprop"
itemprop="name">Carp 3</span></a> <span
class="tots">|</span>
<span class="see-more inline"> <a href="/.../" itemprop='url'>See full options</a>
</span>
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)