$re = '/<span.*?(?:itemprop\s*=\s*"\s*name\s*"\s*)?class\s*=\s*"\s*itemprop\s*"\s*(?:itemprop\s*=\s*"\s*name\s*"\s*)?>(.*?)<\/span>/s';
$str = ' <div class="txt-block" itemprop="contractors" itemscope
itemtype="home">
<h4 class="inline">Employs:</h4> <a href="/.../" itemprop=\'url\'><span class="itemprop"
itemprop="name">Carp 1</span></a>, <a href="/.../"
itemprop=\'url\'><span class="itemprop" itemprop="name">Carp
2</span></a>, <a href="/.../" itemprop=\'url\'><span class="itemprop"
itemprop="name">Carp 3</span></a> <span
class="tots">|</span>
<span class="see-more inline"> <a href="/.../" itemprop=\'url\'>See full options</a>
</span>
</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);