const regex = /<span.*?(?:itemprop\s*=\s*"\s*name\s*"\s*)?class\s*=\s*"\s*itemprop\s*"\s*(?:itemprop\s*=\s*"\s*name\s*"\s*)?>(.*?)<\/span>/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span.*?(?:itemprop\\s*=\\s*"\\s*name\\s*"\\s*)?class\\s*=\\s*"\\s*itemprop\\s*"\\s*(?:itemprop\\s*=\\s*"\\s*name\\s*"\\s*)?>(.*?)<\\\/span>', 'gs')
const str = ` <div class="txt-block" itemprop="contractors" itemscope
itemtype="home">
<h4 class="inline">Employs:</h4> <a href="/.../" itemprop='url'><span class="itemprop"
itemprop="name">Carp 1</span></a>, <a href="/.../"
itemprop='url'><span class="itemprop" itemprop="name">Carp
2</span></a>, <a href="/.../" itemprop='url'><span class="itemprop"
itemprop="name">Carp 3</span></a> <span
class="tots">|</span>
<span class="see-more inline"> <a href="/.../" itemprop='url'>See full options</a>
</span>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}