using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span.*?(?:itemprop\s*=\s*""\s*name\s*""\s*)?class\s*=\s*""\s*itemprop\s*""\s*(?:itemprop\s*=\s*""\s*name\s*""\s*)?>(.*?)<\/span>";
string input = @" <div class=""txt-block"" itemprop=""contractors"" itemscope
itemtype=""home"">
<h4 class=""inline"">Employs:</h4> <a href=""/.../"" itemprop='url'><span class=""itemprop""
itemprop=""name"">Carp 1</span></a>, <a href=""/.../""
itemprop='url'><span class=""itemprop"" itemprop=""name"">Carp
2</span></a>, <a href=""/.../"" itemprop='url'><span class=""itemprop""
itemprop=""name"">Carp 3</span></a> <span
class=""tots"">|</span>
<span class=""see-more inline""> <a href=""/.../"" itemprop='url'>See full options</a>
</span>
</div>";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}