#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=(\boh\b.*?\bwell\b|\bwell\b.*?\boh\b))"
Local $sString = "oh i mean well i do n't know well he 's like oh" & @CRLF & _
"yeah so well he did n't say oh he said f** well you know what he 's like" & @CRLF & _
"oh you know well why well maybe he thought oh well good" & @CRLF & _
"oh my god well what the hell did he oh you know"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")