use strict;
my $str = 'oh i mean well i do n\'t know well he \'s like oh
yeah so well he did n\'t say oh he said f** well you know what he \'s like
oh you know well why well maybe he thought oh well good
oh my god well what the hell did he oh you know';
my $regex = qr/(?=(\boh\b.*?\bwell\b|\bwell\b.*?\boh\b))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}