import re
regex = re.compile(r"(?=(\boh\b.*?\bwell\b|\bwell\b.*?\boh\b))", flags=re.MULTILINE)
test_str = ("oh i mean well i do n't know well he 's like oh\n"
"yeah so well he did n't say oh he said f** well you know what he 's like\n"
"oh you know well why well maybe he thought oh well good\n"
"oh my god well what the hell did he oh you know")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")