$re = '/(?=(\boh\b.*?\bwell\b|\bwell\b.*?\boh\b))/m';
$str = 'oh i mean well i do n\'t know well he \'s like oh
yeah so well he did n\'t say oh he said f** well you know what he \'s like
oh you know well why well maybe he thought oh well good
oh my god well what the hell did he oh you know';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);