import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\boh\\b.*?\\bwell\\b|\\bwell\\b.*?\\boh\\b))";
final String string = "oh i mean well i do n't know well he 's like oh\n"
+ "yeah so well he did n't say oh he said f** well you know what he 's like\n"
+ "oh you know well why well maybe he thought oh well good\n"
+ "oh my god well what the hell did he oh you know";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}