using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(\boh\b.*?\bwell\b|\bwell\b.*?\boh\b))";
string input = @"oh i mean well i do n't know well he 's like oh
yeah so well he did n't say oh he said f** well you know what he 's like
oh you know well why well maybe he thought oh well good
oh my god well what the hell did he oh you know";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}