package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^<id>(.+?)</id>$`)
var str = `<id>0000</id>
<song>Song 1</song>
<id>1111</id>
<song>Song 2</song>
<id>2222</id>
<song>Song 3</song>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}