re = /^<id>(.+?)<\/id>$/m
str = '<id>0000</id>
<song>Song 1</song>
<id>1111</id>
<song>Song 2</song>
<id>2222</id>
<song>Song 3</song>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end