// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^<id>(.+?)</id>$").unwrap();
let string = "<id>0000</id>
<song>Song 1</song>
<id>1111</id>
<song>Song 2</song>
<id>2222</id>
<song>Song 3</song>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}