import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^<id>(.+?)</id>$";
final String string = "<id>0000</id>\n"
+ "<song>Song 1</song>\n"
+ "<id>1111</id>\n"
+ "<song>Song 2</song>\n"
+ "<id>2222</id>\n"
+ "<song>Song 3</song>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}