$re = '~^<id>(.+?)</id>$~m';
$str = '<id>0000</id>
<song>Song 1</song>
<id>1111</id>
<song>Song 2</song>
<id>2222</id>
<song>Song 3</song>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);