# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([A-Z]+)(\d[0-9,.]+)//g;t' <<< "USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
"