using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z]+)(\d[0-9,.]+)";
string substitution = @"";
string input = @"USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}