const regex = new RegExp('([A-Z]+)(\\d[0-9,.]+)', 'g')
const str = `USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);