// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([A-Z]+)(\d[0-9,.]+)").unwrap();
let string = "USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}