import Foundation
let pattern = #"([A-Z]+)(\d[0-9,.]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)