$re = '/([A-Z]+)(\d[0-9,.]+)/';
$str = 'USD1 USD1.00 USD100.00 USD1,000 CAD1,000.00
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;