# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/T\d{2}:\d{2}:\d{2}Z//g;t' <<< "2015-12-22T17:44:24Z"