use strict;
my $str = '2015-12-22T17:44:24Z';
my $regex = qr/T\d{2}:\d{2}:\d{2}Z/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";