import Foundation
let pattern = #"T\d{2}:\d{2}:\d{2}Z"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2015-12-22T17:44:24Z"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)