const regex = /T\d{2}:\d{2}:\d{2}Z/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('T\\d{2}:\\d{2}:\\d{2}Z', 'g')
const str = `2015-12-22T17:44:24Z`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);