$re = '/T\d{2}:\d{2}:\d{2}Z/';
$str = '2015-12-22T17:44:24Z';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;