#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "T\d{2}:\d{2}:\d{2}Z"
Local $sString = "2015-12-22T17:44:24Z"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)