#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^-?$|^\d{1,2}(?:(?<=\d{2})[A-Za-z]\d{0,2})?$"
Local $sString = "VALID" & @CRLF & _
"-" & @CRLF & _
"0" & @CRLF & _
"00" & @CRLF & _
"00X" & @CRLF & _
"00X0" & @CRLF & _
"00X00" & @CRLF & _
"" & @CRLF & _
"INVALID" & @CRLF & _
"-00" & @CRLF & _
"000" & @CRLF & _
"XXX" & @CRLF & _
"-00X00" & @CRLF & _
"-00X0" & @CRLF & _
"-0X0" & @CRLF & _
"-0X" & @CRLF & _
"-X" & @CRLF & _
"-X0" & @CRLF & _
"----------" & @CRLF & _
"AAAAAAAAAAA" & @CRLF & _
"00000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")