re = /^-?$|^\d{1,2}(?:(?<=\d{2})[A-Za-z]\d{0,2})?$/m
str = 'VALID
-
0
00
00X
00X0
00X00
INVALID
-00
000
XXX
-00X00
-00X0
-0X0
-0X
-X
-X0
----------
AAAAAAAAAAA
00000000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end