use strict;
my $str = 'VALID
-
0
00
00X
00X0
00X00
INVALID
-00
000
XXX
-00X00
-00X0
-0X0
-0X
-X
-X0
----------
AAAAAAAAAAA
00000000';
my $regex = qr/^-?$|^\d{1,2}(?:(?<=\d{2})[A-Za-z]\d{0,2})?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}