# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^-?$|^\d{1,2}(?:(?<=\d{2})[A-Za-z]\d{0,2})?$"
test_str = ("VALID\n"
"-\n"
"0\n"
"00\n"
"00X\n"
"00X0\n"
"00X00\n\n"
"INVALID\n"
"-00\n"
"000\n"
"XXX\n"
"-00X00\n"
"-00X0\n"
"-0X0\n"
"-0X\n"
"-X\n"
"-X0\n"
"----------\n"
"AAAAAAAAAAA\n"
"00000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.