using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^-?$|^\d{1,2}(?:(?<=\d{2})[A-Za-z]\d{0,2})?$";
string input = @"VALID
-
0
00
00X
00X0
00X00
INVALID
-00
000
XXX
-00X00
-00X0
-0X0
-0X
-X
-X0
----------
AAAAAAAAAAA
00000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}