# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/?(?:style|link).*?>)/<!-- $1 -->/gm;t' <<< "</style kdskhsjkhds> <link sjdhjd>"