package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(<\/?(?:style|link).*?>)`)
var str = `</style kdskhsjkhds> <link sjdhjd>`
var substitution = "<!-- $1 -->"
fmt.Println(re.ReplaceAllString(str, substitution))
}