import re
regex = re.compile(r"(<\/?(?:style|link).*?>)", flags=re.MULTILINE)
test_str = "</style kdskhsjkhds> <link sjdhjd>"
subst = "<!-- $1 -->"
result = regex.sub(subst, test_str)
if result:
print(result)