use strict;
my $str = '</style kdskhsjkhds> <link sjdhjd>';
my $regex = qr/(<\/?(?:style|link).*?>)/mp;
my $subst = '<!-- $1 -->';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";