$re = '/(<\/?(?:style|link).*?>)/m';
$str = '</style kdskhsjkhds> <link sjdhjd>';
$subst = "<!-- $1 -->";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;