using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/?(?:style|link).*?>)";
string substitution = @"<!-- $1 -->";
string input = @"</style kdskhsjkhds> <link sjdhjd>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}