# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$/\n/gm;t' <<< "%d:%d:%d:%s
%d:%d:%s
%d:%s
%f:%d:%s"