use strict;
my $str = '%d:%d:%d:%s
%d:%d:%s
%d:%s
%f:%d:%s';
my $regex = qr/^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";