#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$"
Local $sString = "%d:%d:%d:%s" & @CRLF & _
"%d:%d:%s" & @CRLF & _
"%d:%s" & @CRLF & _
"%f:%d:%s"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)