const regex = /^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$', 'gm')
const str = `%d:%d:%d:%s
%d:%d:%s
%d:%s
%f:%d:%s`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);