re = /^(?!.*%[^sd])(?!.*%d.*%d.*%d)(?!.*%s.*%s)(?=.*%s).*$/m
str = '%d:%d:%d:%s
%d:%d:%s
%d:%s
%f:%d:%s'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result