#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)N([1-9][0-9]{0,3}[A-HJ-NP-Z]{2}|[1-9][0-9]{0,3}[A-HJ-NP-Z]|[1-9][0-9]{0,4})"
Local $sString = "Should Match" & @CRLF & _
"N12345" & @CRLF & _
"N1234Z" & @CRLF & _
"N123AZ" & @CRLF & _
"N1" & @CRLF & _
"N99" & @CRLF & _
"" & @CRLF & _
"Should not match" & @CRLF & _
"N01Z" & @CRLF & _
"N12PI" & @CRLF & _
"N56OT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")